Project

General

Profile

Actions

Defect #195

closed

strange hashing problems

Added by scott Bakewell over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
FileManager
Target version:
Start date:
04/02/2012
Due date:
% Done:

0%

Estimated time:
keywords:
Platform:
Windows Seven

Description

i just started using d-lan as me and my homies are getting ready for another lan party, but i have had some strange problems when hashing my files. No one else i know has had this issue just me. Most of my files would hash fine, but some would have annoying problems

for example when adding crysis, it would get to nearly 100% and just stop. i left it for a while but wasnt moving anywhere, then i closed the d-lan gui and opened it again and said hashing - 0%. a few minutes later it was still 0%. while doing this it is maxing a cpu core and resource manager shows no disk activity from d-lan core or gui.

now here is where the strange part comes. i renamed the crysis folder to crysis 1, and it hashed all the way through with no problems. so then i tried renaming it back to crysis, and it got stuck at 99.87%. it also worked when i moved it to a different folder, and broke again when i moved it back.

I managed to get all my files hashed in the end after some renaming, but i have no idea what could have caused this. im the only one in my group who has a raid setup, so maybe it has something to do with that? who knows.

heres my specs
intel i5-750 @4ghz
8gb ddr3 1600mhz
msi gtx460 768mb cyclone
asrock p55 pro/usb3
2x WD Green 2TB 5400rpm (raid 0)

Actions #1

Updated by Greg Burri over 9 years ago

Hi,
Thanks for you message.

D-LAN may have some troubles with accessed files during the hashing process. For example if you launch a game and in the same time you share its folder. I've fixed some issue relative to this problem in the 1.1 version, maybe you can try the new version with your Crysis folder : http://www.d-lan.net/ .

I will try to improve the behavior in the current 1.1 branch, I know it's a very annoying issue.

Greg

Actions #2

Updated by Greg Burri over 9 years ago

  • Category set to FileManager
  • Status changed from New to Assigned
  • Assignee set to Greg Burri
  • Priority changed from Low to High
  • Target version set to 1.1
Actions #3

Updated by scott Bakewell over 9 years ago

that update seems to have fixed the issue for me, nice work!

Actions #4

Updated by Greg Burri over 9 years ago

  • Status changed from Assigned to Closed
Actions

Also available in: Atom PDF